Verification of the wallet recovery phrase
Editions: Daedalus, Daedalus Rewards
Navigation
How to navigate to this feature using the User Interface
Select the Wallet that you are interested in checking the recovery phrase for and then go to Wallet Toolbar > More > Settings > Verify wallet recovery phrase
Feature Description
Problem
Sometimes Daedalus users are not sure if they have the correct wallet recovery phrase for their wallets.
A wallet can be recovered only with the correct wallet recovery phrase so it is crucial for users to be sure that they have the correct wallet recovery phrase for wallets that they are currently using to store ada.
IOHK does not have any way to help users to recover a lost wallet recovery phrase. A significant number of users made us aware of this issue by submitting support portal tickets when they needed to delete or restore their wallets and find that the recovery phrase they have does not work.
Cause
Some users have multiple wallets and are unsure of which wallet recovery phrase belongs to which wallet. There may be many other reasons that users do not have the correct recovery phrase for the wallet they want to access.
Solution
The wallet recovery phrase verification feature solves this problem in two ways.
First, this feature will warn users if their recovery phrase has not been verified for a long period of time.
Second, users can check what they think is the correct phrase against the wallet that they think the recovery phrase is matched to. This helps users to maintain their wallet recovery phrases over time because they are prompted to use them more frequently. Previously you only needed to use your recovery phrase when you needed to restore your wallet on another machine.
Note that you can check your phrase using this feature at any time regardless if there is a warning or not.
1. Warnings
Six months after the creation or restoration of the wallet, users will get a yellow warning if the recovery phrase has not been verified. After a year, they will get a red warning. The warning shows as a small red dot on the wallet name in the left side of the Daedalus User Interface. Note that users don’t need to verify their recovery phrase if they are sure it is correct.
2. Verify wallet recovery phrase
It can be accessed from the wallet settings screen by clicking the “Verify wallet recovery phrase” and following simple instructions on the following screens.
1. Navigate to the wallet for which you want to check the wallet recovery phrase by clicking the relevant wallet in the wallet list in the left part of the Daedalus user interface.
2. Click on the "More" tab in the wallet toolbar and select Settings.
3. Click the Verify wallet recovery phrase button.
4. Tick the checkbox on the Wallet Recovery Phrase Verification screen to confirm that nobody can see you screen before you proceed. Then click on Continue.
5. Enter your Daedalus wallet recovery phrase.
6. If the phrase you entered is correct you will see the Verification Successful screen.
7. After returning your wallet recovery phrase to its usual place for safekeeping, click on the tickbox to confirm this is done and then click on Continue.
Release
This feature was added in Cardano 1.7.0: Daedalus 0.15.0 and Cardano SL 3.1.0
For assistance, please submit a ticket to the IOHK support team from the Help menu in Daedalus, or by using the submit a request form.