Machine clock out of sync with Cardano network
Problem
Daedalus is displaying a red screen message related to your machine time being out of sync.
Cause
The time on your computer is not in sync with the network. If the time on your computer is off by more than 1 second from Network Time (used by Daedalus wallet), Daedalus wallet will not be able to connect to the network.
- Note that the 'Connecting to Network' message can be caused by a number of problems. See 'Connecting to Network' message article for more information.
Solution
To fix this issue, you will need to synchronize the time on your computer with a Network Time Protocol (NTP) server. To do this you will need to update the settings of your operating system as shown below.
Using the Daedalus Diagnostics Screen
Navigate to the Daedalus Diagnostics screen:
Click on the Check time button in the Daedalus Status group.
Manual Update Method:
Windows
- Press the Windows key +S (⊞+S)
- Type in Settings
- Go to Additional date, time & regional settings
- Select Date and time settings. A new window will pop up.
- Go to the Internet time tab
- Select Change settings
- Select Update now
- Back to Daedalus, click on Check the time again
Note: there should be a message such as "The clock was successfully synchronized." If there's an error, try selecting Update now again or select a different server from the drop-down menu.
macOS
- Click the clock that is located on the top right of the screen
- Select Open Date & Time Preferences
- Check the lock icon in the lower-left of the settings window. If the lock is closed, click on the lock and enter your computer login password to unlock settings.
- Check the Set date and time automatically box
5. Back to Daedalus, click on Check time again
Linux
- Enable Automatic Date & Time
- Back to Daedalus, click on Check the time again
For assistance, please submit a ticket to the IOHK support team from the Help menu in Daedalus, or by using the submit a request form.