How to verify your spending password
Problem
You are worried if your spending password is correct, and would like to verify it.
Cause
For users who updated from Daedalus 0.15.1 (or earlier versions) to Daedalus 1.0.0 or newer versions, they might not be sure about their spending password. Resetting the spending password requires them to delete the wallets and restore it by using their recovery phrase. This might be considered risky for some users.
Note: If you don't have the recovery phrase, you'll lose access to your Ada forever!
Solution
Within the Daedalus interface, click on More > Settings > change (in the Password box)
Enter the same spending password you have for three times in the password boxes below.
If you can change the password successfully, then it means your spending password is correct.
If it shows your password is incorrect, then your original spending password is wrong, you may need to Reset wallet spending password.
Please see also
How to change your Spending password